letsencryptで証明書更新したらなんかよくわからんがはまった件

※理由は不明。

恥ずかしいことに先日SSL証明書の有効期限切れを起こしてしまい、
更新しようとしたらエラーが出ていろいろ探し回る羽目になったので備忘録です。
※まぁ最終的にはcert.pemをシンボリックリンクにすればよかったのですがなんで最初から
シンボリックリンクになっていなかったのかはなぞ。

一先ず更新してみる。

 

なぜかパースできていないということが分かった。
CertStorageError: expected /etc/letsencrypt/live/example.com/cert.pem to be a symlink

とりあえず対象のフォルダ内を確認し、すべて実態であることを確認してみる。

本来は以下のファイルへのシンボリックリンクでないといけないらしい。

ということでシンボリックリンクに変更した後SSL証明書更新コマンドを実行してみる。

なんかうまくいったみたい。。
念のため確認する。

archiveに新しくできた***2ファイルへリンクされていることを確認。これで今後ははまらなさそうだ。
ついでに自動で更新するようにcrontabに記載しておく。

以上。

letsencryptで証明書更新したらなんかよくわからんがはまった件” に対して1件のコメントがあります。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です